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Baruch College ADA Title II WCAG 2.1 
Cross-College Committee Guidance, February 2026 

Summary 
A cross-college committee convened to review the Web Content Accessibility Guidelines 
(WCAG) 2.1 and to issue clear, focused guidance to the Baruch community on how to 
approach implementing WCAG 2.1 in your digital materials. 

What content is included in WCAG 2.1 guidelines? 

• Websites and mobile apps 
• Learning management systems and content management systems (e.g. 

Brightspace, Blogs@Baruch) 
• Digital documents (e.g., PDFs, Word docs, Excel, PowerPoints) 
• Videos, audio, and multimedia 
• Email communications 

Common Issues to Check and Fix 

Below are the most common issues that need to be fixed to bring content into compliance. 
Please note that this is a simplified and incomprehensive list. For a comprehensive list, 
see the Web Content Accessibility Guidelines (WCAG) 2.1. 

Check 

Start checking Word documents, PDFs, Excel spreadsheets, PowerPoint slides and other 
file types or tools with built in “checkers”. See Accessibility Tools for Microsoft and 
Accessibility and PDFs. Additional guidance and how-to details follow below.   

Fix 

• Hyperlinks: All hyperlinks should be descriptive (not “click here”) and contain 
meaningful words. Links should be distinguished from surrounding text by a means 
other than color alone, for example by underlining the link text.  Links should not 
repeat information and the destination should be intelligible from context or the link 
text. See the Web AIM Hyperlinks Guidance. 

• Captions and Audio Descriptions: Captions should be provided for all 
prerecorded media and should be as descriptive as possible. Machine-generated 
captions alone are not sufficient unless manually reviewed and edited. 

https://www.w3.org/TR/WCAG21/
https://support.microsoft.com/en-us/office/accessibility-tools-for-microsoft-365-b5087b20-1387-4686-a0a5-8e11c5f46cdf
https://helpx.adobe.com/acrobat/using/create-verify-pdf-accessibility.html
https://webaim.org/techniques/hypertext/link_text#urls
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• Text Alternatives: Provide text alternatives (alt text) for any non-text content 
(images, graphs, equations) that is not already described in the text. Alt text should 
be in plain language so that it is understandable to students. For more, see Web 
AIM Alt Text Guidance. 

• Heading Levels: Use heading levels to structure the layout of content. Follow a 
logical heading order (e.g. Heading 3 follows Heading 2, no skipping levels) in 
documents, webpages, Brightspace pages, etc. Heading styles should be used only 
as page hierarchy, not for decorative reasons. 

• Color Contrast: Contrast between text and background should meet WCAG 2.1 AA 
guidelines. Avoid using text over complex backgrounds and avoid red/green or 
blue/yellow combinations. Black text on a white background is always sufficient 
contrast ratio. 

• Use More than Color to Convey Meaning: Color should not be the sole method 
used to convey meaning. Text that is highlighted or colored to make it stand out 
should also be bold or italicized.

https://webaim.org/techniques/alttext/
https://webaim.org/techniques/alttext/
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Baruch Curated WCAG 2.1 Guidance  
The resources below are intended to assist Baruch faculty and staff in updating digital 
materials using the tools and technologies officially provided by Baruch or CUNY, in 
accordance with WCAG 2.1 Guidelines.  
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Microsoft Word 

Font Styles 

Learn 

Choose font styles that are easy to understand and read. It helps to improve the readability 
of the document. 

Check 

• Check that fonts are easy to see and read. 
• From the Ribbon: Select the Home Tab > Font section  
• Arial, Times New Roman, and Helvetica are good font choices. 

Fix 

See: Font Style 

Font Size 

Learn 

https://studentaffairs.baruch.cuny.edu/student-disability-services/creating-accessible-content/quick-easy-tips-for-creating-accessible-microsoft-word-documents/
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Choose font sizes that are easy to see and read. It improves the legibility of the document 
and helps those who are visually impaired.  

Check 

• Check that font size is no smaller than 12 point 
• From the Ribbon: Select the Home Tab > Font section  
• (Consider using 14-point font.) 

Fix  

See: Font Size 

Use of Color 

Learn 

Use of color improves the readability of the document. It makes it easier for everyone to 
see and read, including those with visual impairments.  

Check  

Check that good color contrast is used (foreground against background) 

Fix 

See: Use of Color 

Heading Styles 

Learn 

Use of heading styles (Heading 1, Heading 2, Heading 3, etc.) allows for ease of navigation 
throughout the document for everyone. It is especially important for visually impaired 
users who use assistive technology such as screen readers. Think of an outline for a paper 
as you structure your document using headings. 

Check 

• Click anywhere on the text that should be a heading 
• From the Ribbon: Select the Home Tab > Styles section  
• The style corresponding to the text will be highlighted  

Fix 

See: Heading Styles 

https://studentaffairs.baruch.cuny.edu/student-disability-services/creating-accessible-content/quick-easy-tips-for-creating-accessible-microsoft-word-documents/
https://studentaffairs.baruch.cuny.edu/student-disability-services/creating-accessible-content/quick-easy-tips-for-creating-accessible-microsoft-word-documents/
https://studentaffairs.baruch.cuny.edu/student-disability-services/creating-accessible-content/quick-easy-tips-for-creating-accessible-microsoft-word-documents/
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Navigation Pane 

Learn 

Use the Navigation Pane to assist with a logical heading structure and outline for the 
document.  

Check 

• From the Ribbon, select the View Tab > Show section. Check the box next to 
Navigation Pane.  In browser-based Word, there is not a checkbox. Instead, it is a 
button called “Navigation”.  

• The Navigation Pane will appear on the left side of the document. Select Headings 
to view the outline of the document.  

Fix 

See:  Navigation Pane 

Lists 

Learn 

Lists help with document structure for assistive technology, primarily screen readers. It 
assists the user with understanding how ordered or unordered list items are laid out. Using 
dashes, asterisks, check marks, etc. to indicate a list will not be recognized as a list by 
screen readers and other assistive technologies. 

Check 

• Check that lists are numbered or bulleted using correct structure 
• Click on any part of the list, then from the Ribbon, select the Home Tab > Paragraph 

section  
• The Bullets or Numbering icons will be selected if the list carries either one of these 

formats  

Fix 

See: Lists 

Hyperlinks 

Learn 

https://studentaffairs.baruch.cuny.edu/student-disability-services/creating-accessible-content/quick-easy-tips-for-creating-accessible-microsoft-word-documents/
https://studentaffairs.baruch.cuny.edu/student-disability-services/creating-accessible-content/quick-easy-tips-for-creating-accessible-microsoft-word-documents/
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Hyperlink text should be meaningful. Label hyperlinks correctly using words that describe 
where the link goes. For example: do not use “click here,” “read more,” or “here,” etc. The 
text of the hyperlink should indicate what the user should expect once they activate the 
link. Do not include a long, confusing hyperlink text as users of screen readers often read 
links out of context when navigating documents. Meaningful hyperlink text improves the 
overall usability of the document for everyone. 

Check 

• Visually assess 

 Fix 

• Right click on the hyperlink > Edit Hyperlink  
• In the dialog box that appears, type a meaningful name for the hyperlink in the Text 

to Display box.  In browser-based Word, the field is “Display text”. 
• Select the OK button 

See: Meaningful Hyperlinks 

Images 

Learn 

Create contextual alt text for images to support users of assistive technology, primarily 
those who use screen readers. Images meant to be decorative should be marked as 
“decorative.” 

Check 

• Check that graphics, charts, tables, etc. have descriptive, meaningful alt text. 

 Fix 

• Right click on the image and choose View Alt Text. In browser-based Word, the right-
click menu does not have an alt text option. Instead, there's a button called Alt Text 
in the Ribbon within the Picture tab. 

• The Alt Text dialog box appears on the right side of the document. Type an 
appropriate description of the image in the box. 

• Select the “X” on the upper right corner of the dialog box to close it. 

See: Descriptive Alt Text for Images 

Tables 

https://studentaffairs.baruch.cuny.edu/student-disability-services/creating-accessible-content/quick-easy-tips-for-creating-accessible-microsoft-word-documents/
https://studentaffairs.baruch.cuny.edu/student-disability-services/creating-accessible-content/quick-easy-tips-for-creating-accessible-microsoft-word-documents/
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Learn 

In Microsoft Word, when the column header is set, screen reader users will be able to read 
the column header followed by the associated data cells, which will provide context for the 
user. 

Microsoft Word has the ability to create simple data tables that are limited to only one row 
of column headers.   

Always insert a table by using the Ribbon: Insert Tab > Table > Insert Table. Do not use 
Draw Table. 

Check 

• Place the cursor in the first row of the table and right click. 
• Select Table Properties from the menu. 
• Select the Row tab. 
• Ensure the “repeat as header row at the top of each page” check box is checked. 
• Select the OK button. 

Fix 

The fix is the same as described in the “Check” section above. 

See: Header Row for Tables 

Complex Tables  

Complex tables are generally harder for most people to interpret and understand. 
Consider the following when working with complex tables: 

• Is a complex table necessary? 
• Can the table be simplified? 
• If possible, create smaller separate tables from the larger data table. 
• Provide a table summary. 

Read more about how to make complex tables accessible. 

Built-In Accessibility Checker 

Prior to publishing or distributing the document, use the built-in Accessibility Checker in 
Word. From the Ribbon: Select the Review Tab > Check Accessibility > Check Accessibility. 
The video “How to Use the Accessibility Checker in MS Word” reviews the positives and 
drawbacks of the checker. 

https://studentaffairs.baruch.cuny.edu/student-disability-services/creating-accessible-content/quick-easy-tips-for-creating-accessible-microsoft-word-documents/
https://www.w3.org/WAI/tutorials/tables/
https://studentaffairs.baruch.cuny.edu/student-disability-services/creating-accessible-content/quick-easy-tips-for-creating-accessible-microsoft-word-documents/
https://youtu.be/DpRXuO33xsM?si=8_WVsAWWllU8oYHC
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Converting Word documents to PDF documents 

Microsoft Word documents are commonly converted into PDF documents. When doing so, 
please use the following steps in order to preserve accessibility features: From the Ribbon 
> Acrobat Tab > Preferences: 

• Choose the Settings Tab—check the box next to “Enable Accessibility and Reflow 
with Tagged Adobe PDF.” 

• Choose the OK button.  
• Remaining on the Acrobat Tab > Select Create PDF 
• Provide a file name and choose a destination for the file 
• Choose the Save button 

PDF Files 
PDFs are common and complex file document formats. Though they present several 
challenges from an accessibility standpoint, they have many features to convey 
information—meaning the end result can be information-rich, navigable, and useable by 
all. 

A PDF’s accessibility is defined by features on the document itself as well as in its “hidden” 
components, including its tags, headers, alt text (see our alt text guidance below), 
reading order, and metadata information. 

Importantly, the text of a PDF itself needs to be recognizable and translatable into digital 
text, via the technology of Optical Character Recognition, or OCR. 

Adobe Acrobat Pro offers the most robust accessibility checker for PDFs and lets you fix 
each item as it flags it within the interface. The Acrobat “Prepare for Accessibility” tool 
panel includes an accessibility checker and tools to review and edit a PDF’s tagging, 
reading order, and alt text. 

Scans and OCR (Optical Character Recognition) 

An OCR reading of PDF text is the required standard for course materials under Title II. 
Text that is OCR-readable means that the text has been recognized, digitized, and is 
therefore accurately readable by a screen reader. A scanned textbook page, for example, is 
not accessible until it also has an OCR rendering of the page. The text of a PDF with OCR is 
generally highlightable within the document. Applications like Adobe Acrobat Pro have 
options to run OCR on PDF files, and an OCR option is sometimes available at the moment 

Alt#_Alternative_(
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of scanning a page. Adobe also offers a free, in-browser OCR-creating tool for PDFs, and 
offers OCR rendering in its smartphone app, Adobe Scan. 

Tags 

Tags are hidden structural elements that make up a document’s “outline.” Assistive 
technologies use tags to understand the content of PDFs. Tags identify headings, 
paragraphs, lists, and tables, as well as the logical reading order of content. Adobe 
Reader’s accessibility tools include options for reviewing and editing PDF tags. 

Headings and Styles 

Like in Word documents, PDFs should follow clear and accurate header styles. Adobe 
Reader’s accessibility tools let you adjust PDF headings as needed. 

Alt Text 

See the section on “alt text” below. Alt text facilitates accessible images in PDFs, as with 
other digital media containing images. 

Reading Order 

The reading order of the text should be generally logical on the page, and a PDF will contain 
data about its suggested reading order. Reading order is especially important for PDFs that 
include multiple columns, tables, complex headers or footers, or images. You can scan 
and check for the reading order within Adobe Acrobat Pro’s accessibility tools—and, when 
reading order needs to be adjusted, be prompted to click, drag, and draw boxes on the 
document to indicate the correct order. 

Metadata 

Though not visibly present in the document, a PDF’s metadata provides core information, 
like its title, author, or year of publication/creation. Adobe offers resources on creating and 
editing document metadata for Windows and MacOS users. 

More Info about PDFs and Accessibility 

Check out the Baruch Student Disability Services Office’s Tips for Creating Accessible PDF 
Documents page. 

https://www.adobe.com/acrobat/online/ocr-pdf.html
https://www.adobe.com/acrobat/mobile/scanner-app.html
Alt#_Alternative_(
https://helpx.adobe.com/acrobat/desktop/edit-documents/edit-pdf-properties/create-properties.html
https://helpx.adobe.com/acrobat/desktop/edit-documents/edit-pdf-properties/create-properties.html
https://studentaffairs.baruch.cuny.edu/student-disability-services/creating-accessible-content/quick-easy-tips-for-creating-accessible-pdf-documents/
https://studentaffairs.baruch.cuny.edu/student-disability-services/creating-accessible-content/quick-easy-tips-for-creating-accessible-pdf-documents/
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For more detailed troubleshooting with Acrobat, Adobe offers a comprehensive 
accessibility check and fix guide on its site.  

You can also watch video tutorials on PDF accessibility by the General Services 
Administration of the U.S. government. 

Microsoft Excel Spreadsheets 

Check Accessibility Using Excel’s Built‑In Tools 

Run Excel’s Accessibility Checker to identify common WCAG 2.1 issues. 
• In Excel, select Review > Check Accessibility. 
• Review flagged issues such as missing alternative text, low color contrast, missing 

table headers, and unclear worksheet structure. 
• Treat all Errors as required fixes before sharing. 
• Refer to Excel’s accessibility best practices for detailed instructions. 

Review Worksheet Structure 

• Ensure each worksheet has a descriptive tab name. 
• Confirm content begins in cell A1 (screen readers start reading here). 
• Organize data using simple tables. 
• Avoid merged or split cells. 

Perform a Visual and Keyboard Review 

• Confirm the spreadsheet can be understood without relying on color alone. 
• Confirm the content can be navigated logically using only the keyboard. 
• If either condition is not met, the file likely does not meet WCAG 2.1 expectations. 

Use Proper Tables and Headers 

• Convert data ranges into Excel Tables. 
• Define column headers (and row headers when appropriate). 
• Avoid merged cells and blank rows or columns within tables. 

Add Alternative Text to Visuals 

• Right‑click images, charts, and icons and select Edit Alt Text. 

https://helpx.adobe.com/acrobat/using/create-verify-pdf-accessibility.html
https://www.section508.gov/create/pdfs/training-videos/
https://support.microsoft.com/en-us/office/accessibility-best-practices-with-excel-spreadsheets-6cc05fc5-1314-48b5-8eb3-683e49b3e593
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• Write brief, meaningful descriptions that convey purpose. 
• Mark decorative images as decorative so screen readers skip them. 

Ensure Color Is Not the Only Way Meaning Is Conveyed 

• Do not rely on red/green, shading, or color alone. 
• Pair color with text labels, symbols, or patterns. 
• Confirm text meets minimum color‑contrast requirements (4.5:1 for normal text). 

Use Clear and Descriptive Text 

• Give worksheets, tables, and named ranges meaningful names. 
• Use descriptive hyperlink text (avoid “click here”). 
• Provide instructions or context directly within the worksheet when needed. 

Set Document Properties 

• Add a clear, descriptive file title. 
• Confirm the language is set correctly in File Properties to support screen readers. 

PowerPoint Presentations 

Run the Embedded Accessibility Checker 

• Open PowerPoint and select Review > Check Accessibility. 
• Review issues flagged in the Accessibility pane, including missing slide titles, 

reading‑order problems, missing alternative text, low color contrast, and 
inaccessible tables or media. 

Check Reading Order 

• Use the Reading Order or Selection Pane to confirm slide content is read logically by 
screen readers. 
• Ensure content follows a logical sequence, typically: slide title, body text, then 
images or other visuals. 
• Note this feature is limited in the browser version of Word.  

Perform a Visual Review of the Presentation 
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• Confirm every slide has a unique, descriptive title. 
• Ensure information is understandable without relying on color alone. 
• Confirm text is readable with sufficient color contrast. 

Use Built‑In Slide Layouts 

• Use PowerPoint’s pre‑built slide layouts instead of floating text boxes. 
• Built‑in layouts preserve proper structure and reading order. 

Add Alternative Text to Visuals 

• Right‑click images, charts, and icons and select Edit Alt Text. 
• Describe the meaning or purpose of the visual, not just its appearance. 
• Mark purely decorative images as Decorative so they are skipped by screen readers. 

Ensure Every Slide Has a Title 

• Use the title placeholder on every slide. 
• Slide titles help screen‑reader users navigate efficiently. 
• Titles may be visually hidden if needed but must exist. 

Do Not Rely on Color Alone 

• If color indicates meaning (for example, red/green status), add text labels, symbols, 
or patterns. 

• Ensure sufficient color contrast between text and background. 

Use Accessible Text and Links 

• Use clear, readable fonts and appropriate font sizes. 
• Write descriptive hyperlink text and avoid phrases like “click here.” 
• Avoid excessive animations or transitions that may be distracting or inaccessible. 

Caption and Describe Multimedia 

• Ensure all videos include captions. 
• Provide a transcript for audio‑only content. 
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Alternative (“Alt”) Text for All Images 

What Alt Text Does 

Alternative (alt) text provides a way to access images for users who are blind or have low 
vision. Instead of relying on sight to take in an image, these users can access visual 
content based on a description of it.  

You as a content creator must provide a written description—the alt text—for all visual 
content for assistive technology to convey to the user. If an image does not have alt text, it 
is inaccessible to users of screen readers or similar assistive technology. 

Screen reader software will speak alt text aloud so that a user can hear the image 
described. A mechanical tool called a refreshable Braille display converts alt text into 
Braille by raising and lowering tactile pins so the user can feel each letter. 

Suggestions for Writing Accurate Alt Text 

Alt text should describe the image concisely but accurately, so that users get an equivalent 
experience regardless of whether they are literally seeing the image or using assistive 
technology to sense it in a different way. 

• Write alt text as if you were describing the image to someone over a walkie-talkie 
from miles away. What does the user need to know about the image and why it’s 
being used here? 

• WebAIM has detailed techniques for how to write effective alt text. 
• In academia, some images are very complex. Harvard has good guidance on how to 

make accessible data visualizations, charts, and graphs. 
• Any text that appears within an image must be transcribed in the alt text; otherwise, 

many users will not be able to access its information. 
• Get more details about the issues with text in images; that page is focused on social 

media applications, but the point is relevant across usage types. 
• A simplified accessibility test for this is: Can you select the text in the image? Try 

dragging your cursor over it (on desktop/laptop) or tapping the text (on a mobile 
device). If you cannot select it, assistive technology cannot read it. 

• Don’t write “image of”—it’s not necessary. 
• However, you may have cases where the medium matters, such as describing 

images of artwork (a painting vs. a line drawing in charcoal vs. a bronze sculpture, 
etc.) or other context that impacts the meaning or experience of the image. 

https://afb.org/blindness-and-low-vision/using-technology/assistive-technology-products/screen-readers
https://afb.org/node/16207/refreshable-braille-displays
https://webaim.org/techniques/alttext/
https://accessibility.huit.harvard.edu/data-viz-charts-graphs
https://www.accessible-social.com/images-and-visuals/copy-on-images
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• The Cooper Hewitt Museum offers extensive guidance on describing visual art and 
design. 

• Think about the difference between “The Newman Vertical Campus on a sunny day 
with the Chrysler Building in the background” (safe to assume it’s a photo) vs. “A 
sepia-tone photo of the Chrysler Building taken during its construction in 1929” or 
“An impressionistic pastel painting of nighttime in Manhattan, with the Chrysler 
Building shining behind the Baruch College campus.” 

• Don’t use the file name as the alt text—it is almost certainly not descriptive enough. 
“IMG_0686” is meaningless, and even “Grad_school_fair_2024.jpg” doesn’t include 
the date, time, location, etc. 

How to Add Alt Text Across Common Platforms 

Where and how to enter alt text varies by platform or tool. Use the following resources. 

Microsoft Products 

• Either right-click on an image to bring up an option to View Alt Text or select the 
image, find the Format menu, and click on Alt Text. Here are instructions with 
screenshots for how to add alternative text in Microsoft generally. Below are app-
specific steps. 

• Word instructions for alt text in documents 
• Outlook instructions for alt text in emails 
• PowerPoint instructions for alt text in presentations 
• Excel instructions for alt text in spreadsheets 
• SharePoint instructions for alt text in shared sites 
• OneNote instructions for alt text in notebooks 

Adobe Products and Other Design Tools 

• Acrobat instructions for alt text 
• InDesign instructions for alt text 
• Note that Illustrator does not have an alt text input; you can either import the 

Illustrator file into InDesign and add alt text there or export the Illustrator file as a 
PDF and use Acrobat to add alt text in that file. 

• Photoshop: Click on the image to select it. Then open the Slice tool from the left 
menu. Right-click the image and select Edit Slice Options. Add a description in the 
Alt Tag field. 

https://www.cooperhewitt.org/cooper-hewitt-guidelines-for-image-description/
https://www.cooperhewitt.org/cooper-hewitt-guidelines-for-image-description/
https://support.microsoft.com/en-us/office/add-alternative-text-to-a-shape-picture-chart-smartart-graphic-or-other-object-44989b2a-903c-4d9a-b742-6a75b451c669
https://support.microsoft.com/en-us/office/make-your-word-documents-accessible-to-people-with-disabilities-d9bf3683-87ac-47ea-b91a-78dcacb3c66d#bkmk_altvisuals_win
https://support.microsoft.com/en-us/office/make-your-outlook-email-accessible-to-people-with-disabilities-71ce71f4-7b15-4b7a-a2e3-cf91721bbacb#bkmk_winaltvisuals_o365
https://support.microsoft.com/en-us/office/make-your-powerpoint-presentations-accessible-to-people-with-disabilities-6f7772b2-2f33-4bd2-8ca7-dae3b2b3ef25#bkmk_winalttext
https://support.microsoft.com/en-us/office/accessibility-best-practices-with-excel-spreadsheets-6cc05fc5-1314-48b5-8eb3-683e49b3e593#bkmk_altvisuals_win
https://support.microsoft.com/en-us/office/make-your-sharepoint-site-accessible-to-people-with-disabilities-53707eb5-b7b8-4ee0-ae82-9d4d916f7fe1#bkmk_alttextmod
https://support.microsoft.com/en-us/office/make-your-onenote-notebooks-accessible-to-people-with-disabilities-3c82a6cf-17aa-4e8b-bb2b-7ce210855616#bkmk_addalttexttoimages
https://accessabilityofficer.com/blog/create-accessible-alt-text-in-pd-fs-using-adobe-pro-2026-title-ii-compliance-guide
https://accessibility.psu.edu/pdf/indesign/indesignalttext/
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• Premiere: For video content, “alternative text” takes the form of captions, written 
descriptions, and audio descriptions. Refer to the Video and Captions section 
below. 

• Canva alt text instructions 

Classroom and Third-Party Tools 

• Brightspace instructions for alt text 
• Poll Everywhere instructions for enabling and adding alt text 
• VoiceThread instructions for alt text in a slide 
• Perusall: Uploaded PDFs, even ones with built-in accessibility, will not include alt 

text for any images within them. You will need to use the figure annotation 
(commenting) tool to provide a description for images. See this page for details 
about Perusall’s accessibility of PDFs. 

Baruch Website 

• WordPress instructions for alt text 

Social Media 

• Specifics vary by platform. A great centralized resource is the Image Accessibility by 
Platform (for social media) page maintained by Accessible Social, which has details 
such as step-by-step instructions for each of the major platforms and third-party 
management tools, info about character limits, and more. 

Other Tools 

• LibGuide instructions for alt text 

Video and Captions 

Considerations for Video Captioning 

When creating or distributing video content, you should make sure to have equivalent 
materials available for people who may have trouble seeing or hearing the video. Many 
video hosting services (including Zoom, YouTube, Dropbox, and Vocat) now offer 
automated captioning, which provides an alternative for those who can’t hear a video, but 
it’s important to use integrated descriptions to make sure the caption or transcript offers 
an equivalent experience for those who can’t see the video. Remember that machine 
captions are not enough and any automated captioning should be reviewed for accuracy. 

https://www.canva.com/help/using-alt-text/
https://community.d2l.com/brightspace/kb/articles/1382-improve-your-course-with-brightspace-accessibility-checker#add-proper-image-alternative-text
https://help.canvas.yale.edu/a/1478440-adding-images-and-alt-text-in-poll-everywhere
https://voicethread.com/howto/slide-alt-text/
https://support.perusall.com/hc/en-us/articles/360053405753-How-do-I-highlight-and-create-edit-or-delete-a-comment
https://support.perusall.com/hc/en-us/articles/360053405753-How-do-I-highlight-and-create-edit-or-delete-a-comment
https://support.perusall.com/hc/en-us/articles/1500006240161-Accessibility-for-PDFs
https://wordpress.com/support/wordpress-editor/blocks/image-block/image-caption-alt-text/
https://www.accessible-social.com/images-and-visuals/platform-image-accessibility
https://www.accessible-social.com/images-and-visuals/platform-image-accessibility
https://guides.cuny.edu/accessibility/alt-text#s-lib-ctab-23095954-2
https://www.w3.org/WAI/media/av/av-content/#integrate-description
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For example, the speaker in a cooking video saying, “Whip the mixture until it looks like 
this,” requires the audience to see what is being shown in the video to understand it. 
Instead, the presenter could integrate a more detailed description into the audio by saying, 
“Whip the mixture until the oil, vinegar, and spices are well combined.” That description 
would then automatically be included in captions and transcripts. 

When you plan integrated descriptions before producing a video, you can significantly cut 
the cost and total effort by avoiding the need to go back and fix accessibility issues later. 

If you have already created a video without integrated descriptions, you can create a 
separate audio file with narrations describing important visual details that cannot be 
understood from the main soundtrack (and a verbatim transcript) alone. You can also 
create a text document that acts as an alternative to the video, including sequenced text 
descriptions of visual and auditory information that is presented in the video, as described 
on W3.org’s Media Alternative page. 

Review Video Content  

Do you provide alternatives to your video content that offer an equivalent experience for 
those who have trouble seeing or hearing the video? 

Does the video have visual information that is needed to understand what the video is 
communicating? 

• If no (for example, it is only a person talking): Description is not needed. Consider 
informing users that there is no additional visual content. 

• If yes: Description is needed to provide the important visual information to people 
who are blind and listen to the video. 

If your video has already been recorded without integrated descriptions, either record a 
narrated audio description as a companion to the video or write a text document that acts 
as an alternative to the video, including descriptions of visual elements presented in the 
video. 

More information can be found at w3.org’s Media Alternative page. 

Webpage Structure/Heading Levels 

Key Elements of Webpage Structure 

https://www.w3.org/WAI/WCAG21/Understanding/media-alternative-prerecorded
https://www.w3.org/WAI/WCAG21/Understanding/media-alternative-prerecorded
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• Headings are structural elements that determine the flow of information on a 
webpage. 

• The headings must be used in a hierarchical order.  
• The style of different headings has been defined by the website template. 

Editing Headers in WordPress (Baruch main website and Blogs@Baruch) 

• Editoria11y and WP Accessibility tools are available to help check these settings 
from within WordPress while you edit.  

• Check that heading styles are used to create headings (Heading 1, Heading 2, 
Heading 3, etc.) rather than relying on bold, font size, etc. 

Corrections to Header Structure 

• Highlight text for header 
• Change to correct Header Level (e.g, H1, H2, H3). Don’t skip a header level in 

hierarchical order. H1 is the topmost header, H2 is within an H1, H3 is within an H2, 
etc. To change size of the text, don’t change the header level; use the font size 
setting. 

Color Contrast 

About Color Contrast 

• The visual presentation of text and images of text must have a contrast ratio of at 
least 4.5:1, except for the following:  

• Large Text: Large-scale text and images of large-scale text have a contrast ratio of at 
least 3:1; 

• Incidental: Text or images of text that are part of an inactive user interface 
component, that are pure decoration, that are not visible to anyone, or that are part 
of a picture that contains significant other visual content, have no contrast 
requirement. 

• Logotypes: Text that is part of a logo or brand name has no contrast requirement. 

Tools for Reviewing Contrast 

• Use the WebAIM Contrast Checker 

https://wordpress.org/plugins/editoria11y-accessibility-checker/
https://wordpress.com/support/accessibility/
https://webaim.org/resources/contrastchecker/
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• WordPress will also alert you when editing a page if the contrast between text and 
background colors does not have a high enough contrast ratio. 

Font Sizes  

General Font Guidance 

• While no absolute minimum exists, best practices suggest default body text around 
12pt (16px) and avoiding anything smaller than 9pt (12px) for better usability.  

• Users should be able to resize text up to 200% without loss of content or 
functionality.  

Review Font Accessibility 

• Use WAVE  - Web Accessibility Evaluation Tool   
• If the page theme gives you the option to change font size, make sure the text is 

legible according to WCAG 2.1 
• If there are accessibility errors in the fonts used in WordPress, it must be corrected 

by a network administrator. Please contact BCTC or Blogs@Baruch. 

Links 

Use Specific Hyperlink Language 

Users should be able to understand what will happen when clicking hyperlinks so they can 
decide whether they want to follow them. The simplest thing you can do is make your link 
text clearly describe the destination, using either the page name or a short description of 
its content. You should also avoid simply posting a website’s URL as a link, as screen 
readers will read the entire URL including all colons, slashes, and hyphens. 

It’s especially important to use descriptive link text if the link is part of a list or menu with 
no surrounding text to provide context. If the link is integrated into a paragraph, you can 
include contextual information within that paragraph. For example,   
"Read more about how rainforest research impacts us" 
"Read more about Dr. Ahmed's AI research" 
"Keep reading to learn how XYZ mitigates global warming" 
and so on. Link the unique part with a description rather than the repeated part.  

https://wave.webaim.org/
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The surrounding paragraph provides context to interpret the purpose of the link, and it is 
best practice to put these links at the end of a sentence or paragraph rather than the 
beginning. 

If you use an image as a clickable link, you should also include the link text next to the 
image and put the image and text in a single HTML tag. More detail on how to create link 
tags is available at w3.org. 

If you are comfortable with HTML, you can also use the title attribute to provide a short 
explanation of a link that pops up in the web browser before the user clicks the link. 

More information: 

• W3.org Understanding Success Criterion 2.4.4: Link Purpose (In Context) 
• w3.org Understanding Success Criterion 2.4.9: Link Purpose (Link Only) 
• Rename Hyperlinks 
• Replace ambiguous link text with a page title or brief description of the link 

destination. 
• Place links that rely on descriptive context at the end of the sentence that provides 

that context. 
• Make sure image hyperlinks have adjacent link text and are contained in the same 

HTML tag. 
• Optional: Add the HTML title attribute to links to provide even more information. 

https://www.w3.org/WAI/WCAG22/Techniques/html/H2
https://www.w3.org/WAI/WCAG22/Techniques/html/H2
https://www.nngroup.com/articles/title-attribute/
https://www.w3.org/WAI/WCAG22/Understanding/link-purpose-in-context.html
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